Jump to content
PLC Forum


antonio82ba

ATTIVAZIONE TEMPO DI INGRESSO TRAMITE TAG

Recommended Posts

Panter
Quote

USCITA: monostabile 2 secondi.

 

la risposta non è completa (manca lo stato dell'uscita), se continui così, potrò risponderti solo se metti gli screenshot della programmazione..

Link to comment
Share on other sites


Panter

Forse non sai determinare lo stato dell'uscita nella programmazione. E' NA o NC?

Link to comment
Share on other sites

Panter

non si visualizza niente, comunque a logica, l'uscita non può essere nc.

Hai veramente ,in uscita, selezionato "Normalmente chiusa"?

Link to comment
Share on other sites

antonio82ba

mario sto andando in confusione, ingresso e uscita na; mentre in ingresso si seleziona la voce na, in uscita devo fleggare nc, leggendo nc ho scritto nc, ma ti confermo che è na come l' ingresso. Strano che non vedi i file, li ho caricati nel forum.

Link to comment
Share on other sites

Panter

Li vedo adesso, dopo che li hai rimessi.

Ma se vai in confusione quando programmi come puoi pretendere che le cose funzionino.

 

Se ben ricordi, inizialmente ti ho dato solo degli imput e non volevo darti la procedura scritta perché volevo ci arrivassi da sol (così si impara).

Ritorniamo al problema:

l'uscita è giusto, in questo caso metterla NA, perché dopo comando rimane NC per 2 sec quindi è bene che il transistor rimanga non in conduzione.

 

Detto questo giusto per precisare, in una I/O l'ingresso segue lo stato dell'uscita di conseguenza se l'uscita è NA di conseguenza l'ingresso è NA.

Segumi ora:

Se tu nell'ingresso programmi NC, programmi l'ingresso fisico interno come se fosse un ingresso su morsetto. Ma a quell'ingresso c'è collegata l'uscita che è simile ad un sensore.

Di conseguenza quell'ingresso risulta in allarme (rispetto all'ingresso esterno del sensore simile-uscita che è NA), menre deve risultare a riposo, quindi l'ingresso deve essere necessariamente programmato NA per non avere segnalazione d'allarme. Ecco perché quando hai corretto da NC a NA ti funziona il resto.

 

La conclusione sta nella regola che l'ingresso segue lo stato dell'uscita (la I/O può definirsi anche Uscita controllata), quindi se l'uscita è NC, l'ingresso è NC e se è NA, l'ingresso è NA. ma questo stato rappresenta ciò che è collegato all'ingresso, mentre la programmazione dell'Ingresso riguarda l'ingresso fisico (anche non visibile) come se fosse un morsetto. Dovrebbe essere chiaro a questo punto che se lo stato dell'uscita non coincide con quello che hai programmato l'ingresso, l'ingresso è in allarme continuo a riposo ed è normalissimo che al termine del tempo d'uscita t parta l'allarme.

 

Di tutto, metabolizza almeno che in una I/O, per non avere allarme d'ingresso lo stato deve essere NA o NC sia sull'uscita che sull'ingresso.

 

ps per i Tag è meglio che metti lo screenshot della chiave e del tettore (disabilitare i led non serve a nulla).

Link to comment
Share on other sites

Panter

Dimenticavo...., ecco perché cambiando da NC a NA l'ingresso ora funziona (sempre che il resto sia corretto), ma quello che non va è arrivarci per tentativi, altrimenti in una procedura più complessa non se ne viene a capo.

Link to comment
Share on other sites

antonio82ba

Sinceramente panter sono andato in confusione mentre scrivevo, ma in centrale era tutto na. Tra la bimba che mi girava intorno ed io che mi stavo innervosendo perchè non capivo lo sbaglio....ecco i risultati.

Non guardare l' area antisabotaggio, questo impianto è stato montato da un poco tecnico fac-simile installatore, tanto è vero che il lettore esterno non è protetto da isolatore, motivo per cui lo avevo disabilitato e motivo per cui ora vorrei nascondere lo stato dei led, finchè non ne compro uno.

Ora, non mi interessa inserire/disinserire da lettore, per cui non ho programmato nessuna macro/led per il lettore; circa il tag invece, voglio che all' avvicinamento si accendano i 4 led per cui ho programmato la macro di chiave, ho selezionato solo l' area ingresso (anche nel lettore) e ho fleggato la voce disabilita in disinserimento totale.

Funziona tutto ora, tranne che avendo nascosto lo stato dei led, prima di poter effettivamente azionare la macro di chiave, il lettore mi mostra lo stato dei led e solo al secondo avvicinamento mi avvia il tempo di ingresso, e sinceramente questo mi scoccia un po. Come posso ovviare a questo problemino?

Non riesco a caricare gli screenshot, provo tra un po.

 

 

 

 

 

Link to comment
Share on other sites

antonio82ba

Sinceramente panter sono andato in confusione mentre scrivevo, ma in centrale era tutto na. Tra la bimba che mi girava intorno ed io che mi stavo innervosendo perchè non capivo lo sbaglio....ecco i risultati.

Non guardare l' area antisabotaggio, questo impianto è stato montato da un poco tecnico fac-simile installatore, tanto è vero che il lettore esterno non è protetto da isolatore, motivo per cui lo avevo disabilitato e motivo per cui ora vorrei nascondere lo stato dei led, finchè non ne compro uno.

Ora, non mi interessa inserire/disinserire da lettore, per cui non ho programmato nessuna macro/led per il lettore; circa il tag invece, voglio che all' avvicinamento si accendano i 4 led per cui ho programmato la macro di chiave, ho selezionato solo l' area ingresso (anche nel lettore) e ho fleggato la voce disabilita in disinserimento totale.

Funziona tutto ora, tranne che avendo nascosto lo stato dei led, prima di poter effettivamente azionare la macro di chiave, il lettore mi mostra lo stato dei led e solo al secondo avvicinamento mi avvia il tempo di ingresso, e sinceramente questo mi scoccia un po. Come posso ovviare a questo problemino?

Non riesco a caricare gli screenshot, provo tra un po.

 

 

 

 

 

Link to comment
Share on other sites

antonio82ba

Ho capito la tua spiegazione, copiata negli appunti. Sempre grazie 

Link to comment
Share on other sites

Panter

Per il tag, basta che selezioni "Disinserimento totale disabilitato" che il tag funziona anche al primo avvicinamento.

Dici di aver selezionato "Disinserimento totale disabilitato" ma forse o non hai inviato la programmazione o non hai riprovato dopo.

Deve funzionare al primo avvicinamento, proprio perché non ce n'è più un secondo..

Link to comment
Share on other sites

antonio82ba

Sempre con la macro di chiave come voglio io intendi?

Link to comment
Share on other sites

antonio82ba

Ho scritto in centrale l' intera programmazione ma non cambia nulla.

Se da Impianto SmartLiving>Parametri 50131 fleggo l' opzione LED OFF lettore, il primo avvicinamento mi segnala lo stato quindi il led lampeggia per segnalarmi che un area è inserita, è necessario togliere e riavvicinare il tag per farsì che si attivi la macro di chiave e contestualmente si accendono i 4 led nel lettore. Se tolgo questa opzione l' attivazione dei 4 led è istantanea. E' normale?

Link to comment
Share on other sites

Panter

Nella chiave togli la spunta a servizio che non serve.

Ho visto l'upload per caso, ma... secondo me va usato l'upload (non l'upload/download) in questi casi.

Link to comment
Share on other sites

Panter

la tua risposta è arrivata prima della risposta che ti stavo inviando, quindi non si riferisce all'ultima tua.

Link to comment
Share on other sites

Panter

Lascia stare di disabilitare led lettore, complichi le cose all'utente. Il led acceso aiuta l'utente.

Link to comment
Share on other sites

antonio82ba

Era lo stesso mio grattacapo, oltretutto penso che mia mogli si dimenticherebbe di disattivare un giorno si e l' altro pure. Ho abilitato la macro rossa del lettore per lo scenario totale, senza aree perchè non mi serve inserirlo dal lettore ma così a scenario totale attivo il led rosso è acceso fisso. Te gusta?

Link to comment
Share on other sites

antonio82ba

Ora vorrei passare all' evento panico, cioè accesso in casa sempre con il tag che mi attiva il ritardo, ma all' inserimento del codice diverso mi partono le chiamate in modo silenzioso; go già tra i preferiti la discussione. Ti pongo solo questo quesito.

Nel mio impianto con centrale 515 ho i 5 terminali di centrale occupati, t1 di tastiera collegato al contatto porta e t2 c'è l' I/O TempoIngresso2; non ho espansioni, non posso creare una seconda I/O vero? Potrei crearla sull' espansione ma presumo che questa deve essere collegato all' impianto anche se la I/O è logica e non fisica. Esatto questa mi affermazione?

Link to comment
Share on other sites

Panter

Le I/O le puoi creare sia su centrale che su espansione.

Ma guarda che la I/O è fisica, infatti occupa un morsetto. 

Attenzione ad attivare la funzione panico da lettore con una chiave, ..si può sbagliare facilmente (a meno che non si usi una seconda chiave dedicata).. 

Link to comment
Share on other sites

antonio82ba

Intendo usare un solo codice da dare a tutti i componenti della famiglia, da usare solo per questo scopo; poi a parte ogni componente ha i suo.

Tornando al mio impianto, vorrei che i led rosso del lettore resti acceso quando è inserito lo scenario totale. Se ricordo bene per avere il led acceso devo programmare il lettore in modo che deve poter inserire il totale quindi anche le aree annesse, in caso contrario il led rosso sarà lampeggiante. Mi sembra che non ci siano altre soluzioni, vero? 

Link to comment
Share on other sites

Panter

Da codice non c'è problema.

No, la spia sul lettore si accende con qualsiasi scenario inserito, e non ha importanza se Totale o immediato. E' lampeggiante solo se c'è un allarme in memoria.

Link to comment
Share on other sites

antonio82ba

Scusa se insisto per i led, ma ho provato e il led lampeggia.

Giorni addietro ho chiesto direttamente alla inim il funzionamento dei led e ricordo bene che per le macro di lettore i led restano accesi mentre per i led di chiave dopo un po si spengono. Se tutte le macro di lettore sono disattivate il lettore lampeggia se almeno un area è inserita. Può essere che ricordi bene?

Link to comment
Share on other sites

Panter

Ma quello che dici tu non è un lampeggio è uno spegnimento/riaccensione veloce quasi istantaneo, mentre il vero lampeggio veloce è quando che un allarme scattato e in memoria.

E' normale.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...