Jump to content
PLC Forum


Aieie Brazorv

Regolatore Di Velocità Per un Motorino 12V in cc

Recommended Posts

webdvd

Ok, effettivamente è il minimo che si debba fare!!!

Per il resto era sua maestà NE555 il colpevole del malfunzionamento anche della precedente basetta.

Questa mattina, di buon mattino, ho verificato ed il risultato è stato perfetto.

L'NE l'avevo da parte e chi poteva pensare che era bacato?

Va bè tutto e bene ciò che finisce bene adesso ci mettiamo a studiare il prossimo progetto :smile: ed un grazie alla vostra pazienza e disponibilità!

Link to comment
Share on other sites


Mirko Ceronti
Per il resto era sua maestà NE555 il colpevole del malfunzionamento anche della precedente basetta.

:clap: :clap:

Se ci fosse stata la possibilità di disporre di mun oscilloscopio, sarebbe stato un attimo trovare il problema, anche perchè quei 7 volt e spiccioli che Ti uscivano dal 555 erano regolari come valore.

Peccato però che non fossero a dente di sega, ma.....probabilmente continui...!

Saluti

Mirko

Link to comment
Share on other sites

webdvd

Difatti sullo schema elettrico ce il dente di sega e qualche dubbio m'è l'ero anche posto solamente che le mie conoscenze (quelle poche) si sono consumate con gli anni.....però da qualche tempo m'è ritornata la voglia di fare è oltre che un passatempo la trovo una cosa divertente.....alla fine c'è sempre qualcosa da imparare!!

Link to comment
Share on other sites

Mirko Ceronti
Il mio amico inoltre sarebbe interessato a montare questo circuito sulla sua vecchia lancia Y per regolare a suo piacimento appunto la spazzola del tergi però è scettico riguardo l'IRFZ44 secondo lui troppo debole per reggere il carico

Cosa ? :huh: ????

Gli hai detto che quella canaglia di Mos-Fet sopporta 50 Ampere a 25° di temperatura interna ????

E 35 Ampere a 100° ????

Deve alimentarci il motorino del tergicristallo, o quello di un montacarichi ?

Io ho in laboratorio il motorino del tergicristallo del BMW 318, ed al massimo assorbimento si aggira sui 4,5-:-5 Ampere

Quindi direi che può andare tranquillo.

Oppure sostituisca l'IRFZ44 con un IRF1010, da 84 Ampere a 25° e 60 Ampere a 100°.....ma non mi sembra il caso.

Saluti

Mirko

Link to comment
Share on other sites

webdvd

Credo di aver cantato vittoria troppo presto..........in pratica collegando come carico un motorino di quelli che si trovano dentro le stampanti, tutto ok, la regolazione dei giri è veramente di fino.

Quando però collego una lampadina 12V 10W patatrac, l'NE555 salta, ne ho fatti fuori 4 :worthy: .

Quale potrebbe essere la causa?

Link to comment
Share on other sites

Livio Orsini

Verifica bene i collegamenti allo NE555. Questo componente non nessun nesso con il carico finale: c'è il mosfet, il totempole di pilotaggio e l'AO usato come comparatore di livello.

Se le rotture capitassero con carichi induttivi come i motori, si potrebbe ipotizzare un rientro di spikes dal carico, ma con carico praticamente puro resistivo questo inconveniente non esiste.

Link to comment
Share on other sites

Mirko Ceronti

12 Volt 10 Watt ?

Ma non è neanche un Ampere...!!!

Considerato che il 555 condivide il segnale solo col 3130, e che è quest'ultimo che si interfaccia all'uscita, al massimo mi aspetterei che si bruci lui, non il 555.

E comunque resto convinto che ci sia una manovra che Ti sfugge, in quanto è praticamente assurdo che col motore vada, e con la lampada no, e che costei sia causa della bruciatura di....sua maestà.

Come sottolineava Livio, avrebbe più senso se accadesse il contrario.

Saluti

Mirko

Link to comment
Share on other sites

webdvd

Eppure questo e quanto.......col motorino al minimo dei giri, assorbe 15mA se non ho misurato male e mantiene una bella forza.......praticamente perfetto.Se poi col dito provo a frenarlo lui non molla e l'assorbimento sale anche a 50mA.

O provato anche una ventola da pc e anche con lei tutto bene, poi ho collegato due motorino in parallelo e nessun problema, IRF ghiacciato.

Con la lampadina invece salta il 555 e se poi ci collego il motorino, questo va al massimo e dal potenziometro non si regola più alcunchè!

Link to comment
Share on other sites

webdvd

Signori oggi va anche con le lampadine.....l'unica cosa che ho rilevato, ma appena appena, erano due piste molto vicine ma credo non c'entri nulla visto il comportamento.

Stà di fatto che ora va che è una meraviglia.....stasera lo testerò con un carico importante assieme all'amico scettico :smile: .

Arrivato a questo punto anche se forse sarà OT, vorrei porvi una domanda.

Lo so che è sprecato ma questo circuitino lo vorrei usare per pilotare appunto un motorino recuperato da una vecchia stampante.

Mi piacerebbe riuscire a fargli fare una corsa prestabilita tipo mi sposta un piano per 15 cm in un senso dopo di che inverte il senso e torna indietro...........sarebbe possibile?

O meglio, cosa dovrei cercare tecnicamente parlando per fargli fare ciò di cui ho bisogno?

Link to comment
Share on other sites

Mirko Ceronti

Intanto sei sicuro che il motorino sia un motorino a corrente continua, e non un motorino passo passo ?

(dubbio lecito, visto che si sta parlando di una stampante)

In sostanza se ha 2 fili, va bene, se ne ha dai 4 fili in su, probabilmente no !

Saluti

Mirko

Link to comment
Share on other sites

webdvd

Si il motore ha 2 fili.

Ho provato a collegarlo inverso all'uscita del circuito e gira al contrario.

Link to comment
Share on other sites

Mirko Ceronti

Ok...allora va bene.

Saluti

Mirko

Link to comment
Share on other sites

Ironluk3

Ciao a tutti, cercando e ricercando i motivi per cui il mio circuito non funziona al meglio mi è sorto un dubbio: l'LM336B ha 3 piedini, anodo catodo e adj. l'anodo e il catodo li ho sistemati sul circuito come indicato nello schema ma il piedino dell'adj non ho capito come è connesso e se è connesso al mio circuito...

Grazie

Luke

Link to comment
Share on other sites

Mirko Ceronti

Vai al messaggio 196 di questo Topic

Saluti

Mirko

Link to comment
Share on other sites

webdvd

Stasera abbiamo fatto alcuni test parecchio impegnativi e purtroppo sono saltate due piste.......prima una poi l'altra. Troppo sottili, comunque come carico abbiamo usato una ventola di raffredamento di una macchina che arriva a 17A come ridere di assorbimento.

Va bè dai sono rientrato con la basetta rattoppata ma comunque funzionante :smile: .

Link to comment
Share on other sites

Mirko Ceronti

La tua acerbità (si può dire ?) nel settore, porta Te a tralasciare banalità come quella di "irrorare" di stagno le piste di potenza, (per accrescere la portata in corrente del film di rame depositato sulle basette) ed invece l'esperienza, porta me a dare per scontate queste cose, senza renderle degne di nota.

Che dire....un coctail..."esplosivo" :superlol: !!!!

Saluti

Mirko

Edited by Mirko Ceronti
Link to comment
Share on other sites

webdvd

Hai perfettamente ragione però se anche l'avessi fatto, credo sarebbe risultato invano visto che già in partenza, le ho stampate troppo fine......per la precisione erano due masse.

Il bello è anche questo, sbagliando s'impara :smile: .

Adesso stò ultimando l'altro circuito, quello più semplice, ma con piste a prova di montacarichi!!!

Link to comment
Share on other sites

Mirko Ceronti

Bene !!!

Interessante la corrente della ventola. :smile:

Quando mi serve del carico, non so mai cosa attaccare (lampadine a parte, ma queste non sono ohmico-induttive)

Ho una vecchia motoruota da ex carrello industriale, ma fa un rumoraccio, e non mi va oltre i 10 Ampere.

Credo proprio che mi farò un giro in "demolizione" a reperirne una.

Saluti

Mirko

Link to comment
Share on other sites

webdvd

Già, quella è una ventola di un'Alfa 90 e se l'alimentazione è degna, è capace di assorbire fino a 30A sopratutto se si prova a mettarla sotto sforzo provando a fermarla con le mani, ovviamente quando gira piano :smile: .

Insomma l'amico è rimasto veramente soddisfatto.

Dell'altro circuito non gli piaceva molto la limitazione in corrente. Con carichi importanti, quando ci si avvicina alla minima tensione in uscita si hanno come dire, delle pulsazioni.

Ora lo installerà sul tergi della Y.

Link to comment
Share on other sites

Mirko Ceronti
Dell'altro circuito non gli piaceva molto la limitazione in corrente. Con carichi importanti, quando ci si avvicina alla minima tensione in uscita si hanno come dire, delle pulsazioni.

Evidentemente è passato un concetto distorto sul concetto del limite di corrente.

Costui, non è una normalità, bensì un'eccezionalità per ciò che riguarda questo circuito.

In realtà se tutto va bene, non dovrebbe intervenire mai, e quello altro non sarebbe che un circuito per la regolazione della velocità di un motore DC....punto.

Se però qualcosa va storto, (avvolgimento in corto, bloccaggio dell'albero, e quant'altro) allora interviene il limite di corrente e blocca il tutto per evitare danni.

E comunque non ho ben capito il senso del discorso; cioè accadrebbe che con un carico (ad esempio) da 20 Ampere 12 volt, quando lo alimento a 2 volt (e quindi la corrente è molto più bassa) il limite di corrente non è stabile ?

Ma a quanto è impostato costui ?

Sarei curioso di provare sul mio prototipo.

Saluti

Mirko

Edited by Mirko Ceronti
Link to comment
Share on other sites

webdvd

vediamo se riesco a spiegarmi meglio:

Supponi di usare un motorino 12V (non il mio della stampante) ma uno pressochè simile che assorbe normalmente 0,5A.

Col primo circuito abbassando la tensione in uscita, diminuiscono i giri del motore ma quando si arriva quasi al minimo, appoggiando due dita sopra il motore va a colpetti, poi abbassando ulteriormente si ferma ovviamente.

Pensavamo fosse un discorso legato alla frequenza in qualche modo ma io non sono molto preparato quindi perdonami la superficialità.

Facendo la stessa prova col secondo circuito e con lo stesso carico, questo effetto non sussiste.

Link to comment
Share on other sites

Ironluk3

Oramai ho capito che questa non è la mia materia, però già che ho comprato tutto il materiale volevo giusto due o tre informazioni prima di lanciarmi con la testa contro il muro e lasciare vincere il circuito...

io ho controllato e ricontrollato tutto il circuito e la circuitazione è corretta, le uniche modifiche che ho apportato sono che dato che oramai avevo comprato 3 differenti LM324 (perchè sono ottuso e non avevo capito che era uno solo) e allora ho collegato per tutti e tre massa e Vcc e ognuno utilizza rispettivamente nel primo i pin 1,2,3 poi il secondo 5,6,7 e il terzo 8,9,10. Magari il problema è qui...

un'altra cosa che non và nel circuito è che il mio trimmer è totalmente ignorato, posso girarlo come voglio al max o al min che comunque il motore connesso gira in tutti i casi.

Un'altra domanda per provare a risalire a un eventuale problema, ai capi del trimmer io ho una tensione di 0,60 Volt non è normale giusto?

Ps. LM336B che funzione ha senza il pin adj connesso?

scusate se continuo a rompere, lo sò che sono una piattola e sò anche che è difficile riuscire ad aiutarmi dai qui, è che è la mia ultima risorsa prima di trasformare il circuito nel secondo schema forse un pò più semplice e lasciare perdere la regolazione in corrente...

Ciao e grazie

Link to comment
Share on other sites

webdvd

Bè, io prima di tutto leverei i 2 LM324 giusto perchè sono inutili.

Poi ti chiedo di quale trimmer parli? Se ti riferisci a quello che sullo schema viene chiamato I-Limit, con questo vedi il variare della corrente assorbita dal carico collegato, tramite l'uso di un tester messo in serie.

Tipo se colleghi una lampadina 12V 55W di un'auto, che da accesa assorbe 4,5A circa, col tester in serie e tramite il trimmet I-Limit, puoi decidere di dargli solo 1,5A al massimo.

Link to comment
Share on other sites

Mirko Ceronti
Col primo circuito abbassando la tensione in uscita, diminuiscono i giri del motore ma quando si arriva quasi al minimo, appoggiando due dita sopra il motore va a colpetti, poi abbassando ulteriormente si ferma ovviamente.

Tieni conto di 2 fattori

1) sotto un certo valore di tensione in uscita (e quindi di numero giri nel caso di un motore) si va sotto al limite della coppia critica, ossia il motore non riesce più a trascinare se stesso, e giocoforza si ferma.

2) per un motorino così piccolo, magari servirebbe aumentare il valore dello shunt da 0,1 Ohm, ad anche 1 Ohm, e ciò se da un lato migliora il comportamento dinamico del circuito in limite di corrente, dall'altro penalizza la tensione d'uscita poichè questa volta il motorino si trova non più una resistenza da 1 decimo di Ohm in serie a se stesso, ma da 1 Ohm, e questo penalizza ulteriormente la coppia.

Il circuito più semplice dei 2 non ha tutta l'alchimia di rilevazione della corrente e di aggiustamento di quest'ultima, quindi pompa fuori tutto il possibile (e si guasta se lo accendi col potenziometro puntato al massimo della tensione)

Questo circuitio nasce per motori un po' più grossi di uno da 0,5A per il quale direi che è sprecato.

Per vedere al massimo le performance del limite di corrente senza incappare in problemi di coppia a regimi bassi di giri, ci vuole la lampadina, in quel caso il problema che proceda a colpetti non sussiste.

Altrimenti andrebbe realizzato il circuito del messaggio #59 di questo topic, il quale cerca di mantenere stabili i giri anche sotto sforzo (sempre col limite di corrente che fa buona guardia) ma pure qui, se si scende sotto il limite della coppia critica, il motore si ferma c'è poco da fare, per microvelocità si deve usare il motore a passo

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.



×
×
  • Create New...