Jump to content
PLC Forum


Aieie Brazorv

Regolatore Di Velocità Per un Motorino 12V in cc

Recommended Posts

webdvd

Ho buttato giù la prima bozza del circuito lasciando lo spazio per l'aletta di raffredamento.

75945904.jpg

però un dubbio mi assale.

Una volta tarato a banco come lo collego ai fendi?

Tutt'ora io piloto un positivo con cui do e levo tensione ai fari.

Dallo schema questo positivo lo prendo come si è detto ai capi del BY229 che comunque posso omettere. Quindi se dal punto DC MOTOR prendo il positivo regolato il D dell'IRFZ44 lo metto a massa?

Link to comment
Share on other sites


Mirko Ceronti

Bello :smile:

Lo spazio per l'aletta di raffreddamento non è molto, guardaTi il primo link del messaggio N°# 165 di questo topic, e vedrai che sia il Mosfet che il diodo (che a Te non serve) e lo shunt, sono disposti sul perimetro esterno, per lasciare il massimo spazio a qualunque tipo di aletta.

Quella che tu puoi applicare lì (presumo del tipo a "C") temo sia troppo piccola.

E poi le resistenze come le aletti ?

Saluti

Mirko

Link to comment
Share on other sites

webdvd

Grazie :smile: ma l'ho già rirenderizzata....si dice così?

Stò cercando il modo più semplice per sbrigare le piste.

Come alette ne ho un poche recuperate da vecchie schede.

Ne avrei una appunto a U misura 33mmX15mm, h20mm e spessore 2mm. Sufficente?

Con questa pensavo di mettere il mos-fet coricato.

Vero anche come dici, che in questo modo se dovessi maggiorarla avrei qualche problema.......

La foto del post 165 l'avevo vista ma non riuscivo più a trovarla :smile: .

Alle tre R invece pensavo di interporre tra loro e la vetronite, un pezzo di alluminio.....o farlo a mo di aletta. Potrebbe essere un'idea?

Per l'out invece ho interpretato bene il D dell'IRFZ44 nel precedente post (201)?

Link to comment
Share on other sites

Mirko Ceronti
Una volta tarato a banco come lo collego ai fendi?

Questo è il problema.... :( :(

In tutte le varie disquisizioni sul funzionamento e sui vari dettagli che abbiamo affrontato, mi è sfuggito (colpa mia) quello più importante.

La rigidità dei circuiti dell'automobile, che impongono il Negativo a MASSA.

Ciò rende inutilizzabile questo circuito sull'automobile, anche se in sè per sè funzionerebbe benissimo per regolare la luminosità delle lampade.

Facessi l'elettrauto di mestiere, sarebbe stata la prima cosa che mi veniva in mente, ma avendo una formazione di estrazione industriale (ed essendo nato questo circuito per i motori più che per le lampadine) mi è proprio sfuggito questo (chiamalo così).....dettaglio.

Con la cenere in testa sono a scusarmi per questa "svista madornale" che mi ha depistato, incoraggiandoti ad intraprendere anche economicamente l'avventura.

Sarebbe necessaria una profonda modifica strutturale del circuito, Mos-Fet a canale "P", capovolgimento del segnale di retroazione, e quant'altro.

Come dire : Tutto da rifare.

Oppure andrebbe isolato il percorso del filo negativo che va alla lampada, ma questa su un'auto diventa poesia.

Sorry

Link to comment
Share on other sites

webdvd

Ma figurati, non ti devi scusare anzi, forse è + colpa della mia ignoranza che c'ha portato a questo punto!

Questo circuito ormai lo realizzerò perchè oltre ad avere tutto il materiale, avevo una mezza idea di usarlo per un'altro fine, legato allo sviluppo delle PCB :smile: . Quindi andrò comunque avanti.

Per i fari quindi dovrei mettermi alla ricerca di un nuovo schema elettrico......puoi darmi una mano?

Al post 180 chiesi se era possibile postare un PDF, l'unico circuito per tale fine che ho trovato online ma che però ha dei vincoli che a me non servono e che varrei eliminare se possibile.

Eventualmente potremmo partire da lì.....che ne dici?

Link to comment
Share on other sites

webdvd

Ci siamo quasi, avendo finito i fogli PNP5 stavolta ho usato un lucido. Ho dovuto ripassare un pò le piste.

Piccola dedica al forum........

http://imageshack.us...3/29864153.jpg/

Con questo circuito si riesce a controllare o megli, ridurne i giri di quei mini motori che si trovano dentro le stampanti ad esempio?

Link to comment
Share on other sites

divincodino

Rieccomi qui! :D

ho realizzato il circuito sia come suggerito da Mirko, sia con uno schema da me fatto utilizzando un TL494 più adatto a questo tipo di circuiti, in entrambi casi il circuito funziona, molto meglio con il tl494 ovviamente, ma non ho l'oscilloscopio per vedere le forme d'onda, al simulatore ho una situazione di questo tipo:

le forme d'onda sono tensione al gate del mos e corrente, la corrente ha degli spike al turn-on, anche di un paio di ampere su 20 ampere totali! che riesco a ridurre solo leggermente lavorando sulla resistenza di gate, ma non ad eliminarli, neanche usando una rete di snubber, a cosa può essere dovuto? e soprattutto, nel circuito reale credete ci siano?

so che con un carico induttivo è molto probabile

Link to comment
Share on other sites

Mirko Ceronti
Al post 180 chiesi se era possibile postare un PDF, l'unico circuito per tale fine che ho trovato online ma che però ha dei vincoli che a me non servono e che varrei eliminare se possibile.

Prova a inoltrarlo come hai fatto con quello del PCB (carino pure quello) appoggiandoti all' Imageshack

Però, a questo punto Ti consiglio di aprire un altro Topic, poichè questo, tratta il come regolare la velocità di un motore DC, e non la luminosità dei fari dell'automobile

Capirai che siamo un po' OT :smile:

Saluti

Mirko

Link to comment
Share on other sites

Mirko Ceronti
sia con uno schema da me fatto utilizzando un TL494 più adatto a questo tipo di circuiti, in entrambi casi il circuito funziona, molto meglio con il tl494 ovviamente

Definisci il "molto meglio"....ossia ? :huh:

Cioè in cosa differisce il pwm realizzato col ca3130 ed il 555 da quello realizzato con un circuito dedicato ? (pessima scelta strategica fra l'altro)

Io applicando un segnale variabile in ampiezza tramite potenziometro all'ingresso del 3130 comparato col dente di sega, ottengo un duty cycle a sua volta variabile da 0 al 100% durante tutta l'escursione del potenziometro, e quindi non mi spiego in cosa riuscirebbe in meglio un circuito pensato solo per quello scopo, visto che (lo scopo) risulta il medesimo.

Poi all'atto pratico, conta il comportamento del motore, come funziona meglio il motore col TL494 rispetto a quello col circuito originale ?

Oppure (invece) il circuito non è poi tanto originale, visti i Tuoi post precedenti, dove sono emersi arrangiamenti di ogni tipo ?

Saluti

Mirko

Link to comment
Share on other sites

webdvd

Ok per il nuovo post ma per ora preferisco ultimare questo regolatore.

Oggi ho fatto la prima prova al banco usando una lampadina 12V 10W.

Una volta collegata e dati i 12V dall'alimentatore che in realtà sono 13,5, s'è accesa, poi ho provato a girare il potenziometro e lei s'è attenuata ma poi s'è spenta e non ha dato più segni di vita.

Potrei avere un'aiuto per risalire all'eventuale problema.

Misurando col tester l'uscita trovo i 13V ma tenendo il puntale della massa sulla massa dell'alimentazione.

Se provo sul D dell'IRFZ44 nulla.

PS: tra l'altro stamattina di buon mattino, dopo aver trovato una vera kikka in questo forum, ho stampato per la prima volta la basetta sul lato componenti......spettacolare e comodissimo per il cablaggio.

Edited by webdvd
Link to comment
Share on other sites

Mirko Ceronti

Purtroppo risalire ai problemi per corrispondenza è alquanto difficile.

Non posso che pensare ad un errore di assemblaggio o di circuitazione nel P.C.B. poichè io possiedo 2 (anzi 3) esemplari funzionanti nel mio cassetto di questo circuito.

Ora però dire cosa possa aver aggredito la Tua versione coi dati esposti è critica.

Prova a porre al massimo il limite di corrente (nel senso che il circuito possa erogare la corrente massima) e col puntale del tester sulla massa e l'altro sul 8 dell' LM324 dovresti vedere un'escursione dei volt che va da un minimo ad un massimo in maniera graduale.

Se ciò non accade, allora il problema è a ritroso, se invece succede, allora fino lì ci siamo, ed a quel punto o è nello stadio di P.W.M. o nello stadio di potenza.

Link to comment
Share on other sites

webdvd

Grazie per l'aiuto.

Il trimmer multigiro I-Limit a dir la verità non so se è al massimo (come si può verifivare?)

Comunque col puntale negativo del tester sulla massa di alimentazione e l'altro sul piedino 8 dell'LM324, se ruoto il potenziometro SPEED leggo una variazione di tensione che va da 2,45 a 10,87V in maniera graduale.

Se invece il puntale negativo lo metto sul D dell'IRFZ44 nessuna tensione.

Link to comment
Share on other sites

Mirko Ceronti

Sicuro allora di non aver invertito il bc 337 (NPN) col 327 (PNP) ???

Oppure di averli installati al loro posto, ma invertiti come terminali ? (emettitore al posto del collettore ?)

Se non colleghi un carico in uscita, il trimmer della corrente puoi anche ignorarlo.

Saluti

Mirko

Link to comment
Share on other sites

Ironluk3

Scusate se mi intrometto un'attimo, ho comprato quasi tutti i componenti per realizzare il regolatore con il limite in corrente, ma non sono riuscito a trovare la resistenza corazzata da 25W e 0,1 Ohm...

premettendo che sono nuovo del campo, ho visto che le resistenze corazzate vengono solitamente utilizzate per generare calore, ma in questo circuito che funzione ha? posso rimpiazzarla con una normale resistenza o metto in serie 3 resistenze da 0,1 Ohm e 10W(queste il mio rivenditore le ha)? altrimenti c'è una resistenza da 0,12 ohm e 50W però la mia conoscenza di circuiti elettrici e componentistica è piuttosto limitata e non riesco a capire se quella differenza di 0.02 Ohm possa in qualche modo destabilizzare il mio circuito.

Grazie

comunque gran gran bel sito e gran bel forum :thumb_yello:

Link to comment
Share on other sites

webdvd

Neanche io le ho trovate ed ho messo tre R da 0.33 ohm 10W in parallelo interponendoci un'aletta di alluminio.

Ho controllato minuziosamente la piedinatura del BC337 e BC327 e sono collegati correttamente. Poi ho provato a sostituirli entrambi ma niente da fare.

Altro forse indizio: al Ca3130 trovo tensione ai piedini 2 e 3 ma in uscita sul 6 niente.

L'Ne555 anche lui riceve correttamente alimentazione.

Da ignorante ho come la sensazione che i due transistor non lavorino perchè alle loro basi non arriva nessun segnale........potrebbe essere?

Link to comment
Share on other sites

Livio Orsini
Da ignorante ho come la sensazione che i due transistor non lavorino perchè alle loro basi non arriva nessun segnale........potrebbe essere?

Si anzi è (quasi) sicuro; il vero problema sta nel capire perchè alle basi non arriva alcun segnale.

ma in questo circuito che funzione ha?

E' uno shunt, ovvero è un resistore di piccolo valore che, attraversato dalla corrente del carico, genera una cdt proporzionale alla corrente del carico stesso. In questo caso permette di realizzare una controreazione di corrente di serie per limitare stabilizzare la corrente nel carico.

Link to comment
Share on other sites

webdvd

La cosa che mi vien da chiedere è il senso di quel + e - rispettivamente ai piedini 3 e 2 del CA3130.

Controllando col tester ho due tensioni positive............

Grazie ancora per l'incoraggiamento a districare la faccenda :smile:

Link to comment
Share on other sites

Ironluk3

scusate se mi intrometto ancora...

le resistenze che hai messo tu da 0,33 Ohm sono corazzate o normali?

se uso quella da 0,12Ohm e 50W dite che rischio la stabilità del circuito?

Link to comment
Share on other sites

Mirko Ceronti
La cosa che mi vien da chiedere è il senso di quel + e - rispettivamente ai piedini 3 e 2 del CA3130.

Eh beh...qui ci vorrebbe un corso sugli amplificatori operazionali, scopo che al momento esula da questo Topic.

Il CA3130 come anche l'LM324 di questo circuito sono amplificatori operazionali, ovvero eseguono somme o differenze (operazioni appunto) algebriche dei segnali.

In questo caso, utilizzando il CA 3130 come comparatore (la versatilità degli operazionali ha un solo vincolo : la fantasia del progettista) quando il segnale sul pin 3 supera quello sul pin 2, l'uscita 6 va ad 1 logico, che vuol dire che passa da 0 volt (massa) a quasi la tensione di alimentazione. Analogamente, quando la tensione sul pin 3 va sotto come livello a quella sul pin 2, l'uscita passa da 1 logico a zero volt.

Ora, applicando un simil-dente di sega al pin 2 (segnale che va da un valore prossimo allo zero fino a quasi tutta la tensione di alimentazione, in un "crescendo" lineare ed in un "calando" improvviso) e comparandolo con un segnale (pin 3) lineare che può variare sia per effetto della regolazione a potenziometro, (velocità o luminosità) che per effetto della sovracorrente, noi otteniamo in uscita (pin 6) un'onda quadra i cui fronti "mark" (impulsi di segnale) possono variare in larghezza rispetto a quelli di space (assenza segnale) a seconda appunto del livello di tensione che si trova sul pin 3.

Saluti

Mirko

Link to comment
Share on other sites

webdvd

Tanto di cappello per la chiarezza della spiegazione ma come dici, dovrei riprendere in mano i libri.........comunque nonostante la tensione variabile al pin3 e la fissa al pin2, in uscita non mi da nulla.

Ho provato a sostituire il 3130 ma nulla. Ho controllato il BY229 che in realta è un BYW29E (ho trovato questo) e funziona correttamente. I 2 BC li escludo perchè controllati e provato anche a sostituirli ma nulla. Provato anche a sostituire l'NE555 e niente da fare.

Non so se può essere d'aiuto ma è normale che dando alimentazione al circuito trovo la stessa tensione sul D dell'Ercolino?

Come posso verificare il corretto funzionamento dei due condensatori al pin 7 e 8-1 del CA3130?

Ormai è diventata una sfida e poi trovo che risalire al problema sia quasi più soddisfacente che realizzare l'intero circuito........va bè, ammetto che fortunatamente succede poche volte :P .

Link to comment
Share on other sites

Ironluk3

Scusate ancora la mia inesperienza, se al posto della resistenza corazzata da 0,1 Ohm e 25W metto una da 0,12 Ohm e 50W mi può andare bene lo stesso?

nel negozio dove vado non hanno quella da 0,1Ohm e 25W, e pensavo anche se molto sopradimensionate di mettere 2 resistenze corazzate in parallelo da 0,22Ohm e 50W ma non hanno neanche quelle!!!

quella da 0,12Ohm ce l'hanno e facendo due calcoli(sempre che siano corretti) la differenza tra quella 0,10 e 0,12 Ohm risulterebbe in un lasciare passare tipo 0,5 A in più, potrebbe danneggiare i componenti?

Edited by Ironluk3
Link to comment
Share on other sites

Mirko Ceronti
Scusate ancora la mia inesperienza, se al posto della resistenza corazzata da 0,1 Ohm e 25W metto una da 0,12 Ohm e 50W mi può andare bene lo stesso?

Va benissimo, non preoccuparti :smile:

Saluti

Mirko

Link to comment
Share on other sites

Mirko Ceronti
Non so se può essere d'aiuto ma è normale che dando alimentazione al circuito trovo la stessa tensione sul D dell'Ercolino?

Se per Ercolino intendi il Mos-Fet, e se costui non sta pilotando il carico (che deve però risultare collegato all'uscita), e Tu metti il puntale positivo sul Drain, ed il negativo a GND (massa) è normale !

comunque nonostante la tensione variabile al pin3 e la fissa al pin2, in uscita non mi da nulla.

Qui può esserci solo un errore, poichè la legge degli operazionali non l'ho scritta io; come puoi vedere dai grafici, col pin 3 al massimo della tensione conferitagli dal pin 8 del 324, in uscita al pin 6 non puoi che avere quasi la tensione di alimentazione.

Abbassando il valore sul pin 3, in uscita pin 6 avrai un abbassamento del valore medio, da interpretare come una riduzione del rapporto di duty cicle .

Come posso verificare il corretto funzionamento dei due condensatori al pin 7 e 8-1 del CA3130?

Non credo Tu possa verificarlo, ci vorrebbe un oscilloscopio.

Posso solo dirTi che se usi un 47pF al posto del 470pF tra pin 8 e pin 1, tutto il circuito funziona male, il 100nF sul pin 7 è contro il rumore elettrico sull'alimentazione, si monta d'ufficio.

Controlla e ricontrolla maniacalmente il P.C.B. non vorrei che ci fossero degli errori su quello.

Saluti

Mirko

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.



×
×
  • Create New...