Jump to content
PLC Forum


Aieie Brazorv

Regolatore Di Velocità Per un Motorino 12V in cc

Recommended Posts

c1anc10

Da quello che ho capito dovrebbe servire solamente come riferimento di tensione per il limitatore di corrente. A tale proposito mi stavo appunto chiedendo se non si potrebbe sostituire con uno zener di basso valore.

Vorrei sapere come mai è stato usato un opamp così performante come il CA3130. A dire il vero non so di che frequenza stiamo parlando, ma a occhio siamo su qualche decina di kHz, il 324 non ce la fa?

Link to comment
Share on other sites


Mirko Ceronti
il 324 non ce la fa?

Coi valori dei componenti che vedi a schema...NO... :( !!!!!

Saluti

Mirko

Link to comment
Share on other sites

divincodino

Rieccomi qua dopo tanto tempo a massacrarvi il cervello!!!! :D specialmente a voi, Mirko e Livio

Ho finalmente montato il circuito su piastra sperimentale, la parte di potenza su piastra millefori data la corrente più alta.

Ho dimensionato il circuito attualmente per sostenere una corrente di 2 ampere (limite dell'alimentatore) e uso come carico una lampada per auto H4 a 12V ovviamente.

2 Risultati fondamentali, che si verificano anche se come carico uso una semplice ventola:

- il circuito emette un fischio, non so se dovuto forse alla frequenza di commutazione elevata

- la limitazione in corrente non agisce in alcun modo, anche se sostituisco al trimmer una resistenza di valore basso per portare il primo amplificatore ad avere l'uscita bassa; in sostanza ho cercato diversi stratagemmi per vedere di far agire la limitazione ma niente da fare :(

Link to comment
Share on other sites

divincodino

Nuovo aggiornamento:

- il fischio è dovuto proprio alla frequenza di commutazione, abbassandola esso scompare quando la velocità è settata al massimo, ricompare sempre più forte quando vado a regolare il pwm con il potenziometro; si può fare qualcosa per eliminarlo?

- la regolazione della corrente invece continua a non aggire, con il settaggio attuale del trimmer leggo una tensione sulla resistenza di shunt superiore a quella di riferimento, un led posto tra alimentazione e uscita del primo AO è acceso, a segnalare che l'uscita del primo AO scende, tuttavia la corrente non viene regolata. Sul ramo di retroazione attualmente uso una resistenza di 10k e un condensatore di 4.7nF, in quanto sono gli unici valori che ho in casa adesso. D'ALTRA PARTE, ho anche provato a collegare il + del primo AO a massa, cioè usare 0V come riferimento, e questo dovrebbe tenere il mos sempre spento, correggetemi se sbaglio, invece anche in questo caso non cambia niente.. non riesco proprio a capire, ho ricontrollato i collegamenti 50 volte

Dimenticavo: al posto di un ca3130 sto usando un LM358, che in alcuni siti me lo porta come equivalente, anche se in realtà non lo è!

Edited by divincodino
Link to comment
Share on other sites

Livio Orsini

Scusa ma hai misurato cosa esce dal secondo 324 con corrente inferiore alla soglia e con corrente superiore alla soglia?

Perchè il sistema è semplice: l'uscita del secondo 324 fa variare in più o in meno l'uscita del terzo 324 che funzione di comparatore con il dente di sega generato dal 555, in questo modo varia il duty cycle del comando del mosfet.

Link to comment
Share on other sites

divincodino

Gentile Livio,

non ho un oscilloscopio, misurando semplicemente con il tester mi riporta una tensione di 3,5V all'uscita del secondo AO.Ho misurato adesso la corrente sul carico tramite il tester, e nonostante cerco di limitare la corrente ad 1A, la corrente che scorre è di 1.9A circa, la massima che l'alimentatore riesce a dare (è un alimentatore per HD esterni da 12V, 2.2A), sia che colleghi il riferimento a massa, sia che usi il trimmer, anche agendo su di esso il valore di corrente non cambia. Il funzionamento è semplice, infatti non ho avuto problemi a capirlo, e la regolazione della velocità tramite potenziometro funziona perfettamente, proprio per questo non capisco il mancato funzionamento della regolazione di corrente

un'altra cosa, giusto per chiarire: all'uscita del primo AO ho collegato un led con resistenza, tra alimentazione e uscita, in tal modo visivamente se la limitazione di corrente non agisce il led sarà sempre spento, e anche al simulatore, con i valori dei componenti utilizzati nella pratica, il circuito funzionaperfettamente. Nella pratica invece, il led si accende, ma la corrente non viene limitata

Edited by divincodino
Link to comment
Share on other sites

Livio Orsini

Togli il collegamento al resitore di shunt e sostituiscilo con un potenziometro alimentato tramite un resistore dal +12V. In pratica dai un valore di tensione fisso e fai tutte le misure con il tester.

Parti con valere 0 V ti annoti i valori di tensione all'uscita dei 3 ampli; prima però togli il led che può creare variazioni nelle tensioni.

Sali gradualmente con la tensione del potenziometro, simulando un valore di corrente crescente, ti annoti le tensioni all'uscita dei 3 ampli sino a quando noti una diminuzione della tensione di uscita.

Certo che senza oscilloscopio è un po' più labariosa e grossolana la verifica, però si può fare tranquillamente.

Link to comment
Share on other sites

divincodino

Grazie mille per l'idea!!!! non avevo pensato a questa prova, eseguo subito

:)

Link to comment
Share on other sites

divincodino

Questi sono i risultati finora:

AO1: tensione imposta al + 0,1V

tensione al - (AO1) UAO1 UAO2 UAO3

0V 0,7V 6,3V 0,6V

0,85V 0,6V " "

2V 0,6V " "

4V 0,6V " "

10,3V(max) " " "

In pratica non succede niente, e in questa configurazione non funziona neanche il potenziometro del pwm

Link to comment
Share on other sites

divincodino

Livio tu (o lei :D ) sei miracoloso anche senza fare niente! adesso rimontando il circuito come prima, cioè togliendo il potenziometro da te suggerito, tutto miracolosamente funziona! inspiegabile, ci sarà stato qualche piedino che non faceva ben contatto :wacko:

Unica pecca che non capisco, ma che penso, correggetemi, dipenda dalla tensione minima del dente di sega: portando al minimo il trimmer della corrente, la lampadina non si spegne del tutto, la corrente non scende al di sotto di un valore minimo in pratica, ed in effetti ho lo stesso comportamento (dei picchi) anche al simulatore, mentre dovrei avere una tensione sempre nulla in uscita

Link to comment
Share on other sites

Livio Orsini

Strano davvero. Bastano pochi mV in più sulla R da 100k, rispetto a quella da 10k (primo 324), perchè lìuscita del terzo 324 scenda a meno di 100 mV. Questo causa un duty cycle di circa 0%.

Con le 2 tensioni uguali, o con quella su R 100k minore, l'uscita del terzo LM324 è praticamente eguale al valore impostato dal potenziometro di riferimento velocità.

Ho appena effettuato le misure su di un circuito dummy che ho sul banco.

opps non avevo visto il tuo messaggio #160

Edited by Livio Orsini
Link to comment
Share on other sites

divincodino

tranquillo :)

nuovo aggiornamento: a causa del fischio, ho cambiato la frequenza, da circa 1KHz (ho pensato che il fischio dipenda dallìessere nella frequenza dell'udibile) l'ho portata a 15KHz circa, valori max min del dente di sega rispettivamente 12V e 1V. Adesso con carico massimo nessun fischio, portando a zero il trimmer della corrente o il potenziomentro la lampada si spegne come dovrebbe, tuttavia agendo alternativamente sui due potenziometri, quindi regolando la commutazione, il fischio torna a risentirsi, ed è la lampada ad emetterlo, come se agisse da amplificatore audio

Link to comment
Share on other sites

Mirko Ceronti

E comunque....

Le performance di questo circito sono da intendersi a componenti originali come da schema !!!!!!

Arrotolarsi sui vari perchè e percome quando non si usa il 3130 perchè non lo si possiede (e si cerca di ottenere lo stesso risultato col 358); quando la rete d'integrazione RC viene variata di valore sempre per lo stesso motivo, e quant'altro, è un "voler non posso"

Anzi debbo dire che sei stato bravo a farlo funzionare comunque anche col 358, io ai miei tempi non ci riuscii.

Inoltre gli errori di saldatura o di cablatura son sempre dietro l'angolo, quindi ATTENZIONE perchè si corre il rischio di riempire il Forum di messaggi e contromessaggi, cercando un aiuto che (se si è sbagliato qualcosa) si fa arduo, poichè bisognerebbe essere lì sul posto e verificare di persona.

Ringrazio inoltre Livio, :smile: per il supporto dato in mia assenza ad un circuito non suo, ma che comunque si è prodigato a voler interpretare per dare un aiuto a Divincodino.

Ho costruito proprio in questo Week-End un altro esemplare di questo circuito, e funziona a meraviglia, MA....con componenti coma da schema, e senza arrangiamenti di alcun genere.

Saluti

Edited by Mirko Ceronti
Link to comment
Share on other sites

Livio Orsini
Ringrazio inoltre Livio

Figurati, Mirko quando è possibile dare una mano ad un appassionato lo faccio sempre volentieri. Poi cerco sempre di capire e spiegare anche agli altri come funzionano i vari circuiti.

Tra l'altro, se vuoi divertirti, se rimuovi l'integratore a quel tuo limitatore di corrente potrebbe funzionare da microstepping per motori stepper.

Link to comment
Share on other sites

Mirko Ceronti

Eccolo qua, fresco di foto.

Mancano (in questo esemplare) il 7812 ed i vari componenti di filtro sulla 12 Vca, poichè attinge (per l'applicazione a cui è destinato) direttamente l'alimentazione da una batteria a 12 Volt, che è poi quella che alimenta anche il motore DC (quindi proprio come da schema del messaggio originale e non come nel messaggio #24)

http://upload.plcwww...olo-2_thumb.jpg

http://upload.plcwww...olo-1_thumb.jpg

Edited by Mirko Ceronti
Link to comment
Share on other sites

divincodino

Caro Mirko,

hai perfettamente ragione in tutto, d'altra parte sono molto ostinato e volevo necessariamente farlo funzionare :smile:

Non mi saltano agli occhi tutti i motivi per cuiil ca3130 sia il miglior componente per il lavoro che deve svolgere, credo forse il più importante sia la banda di 15MHz, contro mi pare pochi MHz del 358.

Anche io non ho usato il 7812 perchè parto da un alimentatore 12V, riguardo gli errori di collegamento hai centrato in pieno, tuttavia prima di scrivervi ho ricontrollato per 2 ore tutti i ponticelli, evidentemente era destino che dovesse aiutarmi Livio :D

Vorrei chiederti 2 cortesie:

- come realizzi i circuiti stampati? puoi indicarmi tutto il materiale, che tipo di basette usi, e come le realizzi, perchè si vede che sono fatte diciamo amatorialmente, ma fatte molto bene;

- vorrei capire come si dimensiona il filtro RC sulla retroazione

Grazie di tutto

PS: è vero che ho modificato quei componenti, e anche altri sul NE555, ma non proprio a caso, li ho modificati prima al simulatore in base ai componenti a disposizione per generare la forma d'onda che volevo io alla frequenza da me voluta, ovvio che poi nella pratica il comportamento non sarà perfetto, ma è andato più che bene; l'unico neo che resta è il fischio quando vado a modulare la tensione

Edited by divincodino
Link to comment
Share on other sites

Livio Orsini
i motivi per cuiil ca3130 sia il miglior componente per il lavoro che deve svolgere, credo forse il più importante sia la banda di 15MHz, contro mi pare pochi MHz del 358.

E si è proprio questione di banda, quindi di slew rate risultante. Se tu disponessi di un buon oscilloscopio potresti vedere i fronti di commutazione.

Link to comment
Share on other sites

GiRock

Livio, hai del Veggente :smile:!!!

Pensa che lo stavo scrivendo io quando ho visto comparire la tua risposta, praticamente il 358 è troppo lento con i suoi 0.6V/us, mentre il CA3130 ha come minimo uno slew rate di 10V/us, praticamente un altro pianeta, detto questo se persegui quell'obiettivo hai ben poca speranza di farlo funzionare così com'è stato progettato dal mitico Mirko :superlol:...

Tieni anche presente che uno contiene transistor e l'altro mosfet, se vuoi una risposta rapida devi per forza passare ad un livello superiore in tutti i sensi...

Link to comment
Share on other sites

divincodino

completamente d'accordo ;)

Livio scusami, tu che sei un veterano, vorrei chiedervi dei consigli sulla costruzione di un "grosso" alimentatore, apro un altro post o posso farlo qui?

Link to comment
Share on other sites

Livio Orsini
Livio, hai del Veggente :smile:!!!

Hei Gio è solo questione di età :wacko: E' più di mezzo secolo che traffico con sta robaccia. Pensa che 50 anni fa gli amplificatori operazionali si costruivano con una decina di transistros (ne feci uno con gli OC44 al Ge). Ho anche una foto di un magnifico OA costruito con due doppi triodi (credo fossero 12AX7 ma non son sicuro della sigla), il tutto montato in uno scatolotto.

apro un altro post o posso farlo qui?

No, è meglio aprire un'apposita discussione.

Edited by Livio Orsini
Link to comment
Share on other sites

Mirko Ceronti
- come realizzi i circuiti stampati? puoi indicarmi tutto il materiale, che tipo di basette usi, e come le realizzi, perchè si vede che sono fatte diciamo amatorialmente, ma fatte molto bene;

Io pratico il metodo della fotoincisione, con l'uso di basette presensibilizzate (no metodo dello spry fotosensibile, è troppo critico), ma qui sul Forum, c'è chi non disdegna neanche un altro metodo che trovi a questo link

http://elettronica.plcforum.it/index.php?/topic/923-tutorial-per-realizzare-stampati/

Dagli uno sguardo perchè ne vale la pena, è molto ben esposto.

vorrei capire come si dimensiona il filtro RC sulla retroazione

Eh, qui non posso aiutarTi poichè dovrei inculcarti il mio istinto.

La formula sarebbe Tao = R x C, ma io causa (o grazie) all'esperienza, li calcolo a "sensazione".

Mi spiego : io mi cibo di riviste di elettronica dal lontano Giugno 1981.

Ormai ho assimilato che in un transistor alimentato a 12 volt che deve funzionare da interruttore, una resistenza in base da 1K va più che bene, sia esso un bc 337, 2N1711, BDX33, e se si parla di un darlington ce la fai anche con una 10K.

Per cui non mi metto lì certo a calcolarla in funzione del guadagno di ogni singolo componente utilizzato, e se la tensione raddoppia, io raddoppio la resistenza....tutto qua.

A questo si aggiunga che lavoro su breadboard, quindi nulla di più facile, caccio su il componente che ritengo andar bene, e se fallisce amen, lo cambio con un altro valore.

Questo per trasmetterTi il concetto che quando progetto un circuito elettronico, difficilmente ricorro ai calcoli, i quali richiedono più tempo della diretta prova sul campo. (si fa prima)

Oh, non è sempre così, a me "fare i conti" piace molto, quindi se capita di dover dimensionare un componente il cui errore può portare ad una catastrofe elettrica, allora prima di bruciare tutto, il calcolo lo faccio eccome, ma dove l'occhio e l'esperienza acquisita negli anni è più rapida (ed a volte anche più precisa) del calcolo, e dove l'eventuale errore non implica nulla di devastante, ma solo un malfunzionamento, poca prosopopea, caccio su quello che per me può andar bene e verifico al volo il risultato, e l'oscilloscopio m'aiuta molto.

Ora nel caso specifico, quando ho dovuto realizzare l'RC per questo circuito, d'istinto ho cacciato su subito una 100K ed un 100nF e mi son detto "vediamo".....è andata bene, quindi mi son posto pochi problemi e son andato avanti.

Più circuiti progetti, e più Ti accorgi col passare del tempo che sempre meno ricorri ai calcoli.

Oh, poi dipende anche in che campo dell'elettronica operi, sicuramente in AF o in BF di conti se ne fanno comunque di più, e sicuramente chi ne progetta tutti i giorni ne farà meno di chi realizza un amplificatore ogni anno bisestile.

Saluti

Mirko

Link to comment
Share on other sites

divincodino

Grazie mille, nella scelta dei componenti per il dente di sega anche io sono andato a sentimento, sapendo che avrei dovuto diminuire la capacità ed in corrispondenza dare più o meno un certo valore alla resistenza, alla fine spesso si risolve così ;)

Grazie anche per il link sulla realizzazione dei circuiti, se trovi qualcosa anche sulla fotoincisione fatto altrettanto bene ti sarei grato ;)

saluti

Giuseppe

Link to comment
Share on other sites

Mirko Ceronti

se trovi qualcosa anche sulla fotoincisione fatto altrettanto bene ti sarei grato

Link to comment
Share on other sites

divincodino

Grazieeeeeeeeeeee Mirko

(Sono stato molto furbo a non guardare su youtube :D )

Link to comment
Share on other sites

divincodino

Riciao a tutti, una domanda apparentemente stupida, ma mi sorge da alcuni circuiti visti in rete...

Nei vari circuiti che permettono di regolare la velocità dei motori DC in PWM, alcuni inseriscono un condensatore, tipicamente da 3300-4700 uF, in parallelo al carico, che in questo caso è il nostro motore... è utile? non basta l'effetto filtrante del motore?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.



×
×
  • Create New...