Jump to content
PLC Forum


Aieie Brazorv

Regolatore Di Velocità Per un Motorino 12V in cc

Recommended Posts

divincodino

Forse sono io che parlo un'altra lingua :D il segnale sul "-" è quello che vi ho presentato nella prima immagine, la tensione sullo shunt, il segnale sul "+" l'ho fissato io a 2,5V con un generatore di tensione, quindi è stabile

Link to post
Share on other sites

Livio Orsini
Forse sono io che parlo un'altra lingua

O magari usi una lingua per differente a seconda del messaggio! :lol:

Queste sono le didascalie delle tue "foto":

- il primo segnale è l'uscita (tensione) del primo LM324 (quindi l'uscita dovrebbe scendere quando si supera il limite di 25A sullo shunt)

- il secondo segnale è la tensione al gate del mosfet

- il terzo segnale è la corrente sul mosfet e quindi sullo shunt, come vedete arriva al doppio del valore di limitazione

Poi dovresti anche rimettere il condensatore di filtro verso massa.

Edited by Livio Orsini
Link to post
Share on other sites
Livio Orsini

Se quella è la tensione in ingresso al comparatore evidentemente c' qualche cosa che non va bene o nel simulatore o nel circuito che hai usato. Ti ripeto: rimetti il circuito come l'originale, assicurati che il motore abbia un valore di in duttanza e resistenza congruo al modello reale, verifica che la tensione di riferimento sia realmente un valore costante senza oscillazioni (a volte i simulatori fanno delle spiacevoli sorprese).

Non ci possono essere misteri: quando i due valori di tensione hanno una differenza maggiore dell'offset l'uscita del comparatore è o alta o bassa. Purtroppo lo LM324 non è un fulmine di guerra quindi tende a sdraiare un poco i fronti, però dovrebbe rieuscire a fare il suo dovere, spostando la soglia di commutazione del PWM.

Verifica i 3 segnali: 2 ingressi ed uscita.

Link to post
Share on other sites
divincodino

proverò a fare come dici :) sai indicarmi un foglio tecnico di un motore dc? ho trovato solo alcuni dati, con un valore di induttanza di 700uH (io nel simulatore ho messo 100uH)

Link to post
Share on other sites
divincodino

Caro Livio,

trovo pochi costruttori che rendono disponibili i valori di induttanza di armatura, ho trovato dei motori DC di una ditta da 125 a 250W che hanno valori di induttanza da 1,05mH a 4,65mH, nel mio caso sono 500W, diciamo che se simulassi con un'induttanza di 2mH non dovrei essere molto lontano dalla verità, giusto? già con 700mH al posto dei 100mH da me ipotizzati inizialmente il circuito si comporta molto meglio, credo che i problemi con piccolissime induttanze siano nei tempi di risposta degli amplificatori

Link to post
Share on other sites
Livio Orsini

700 mHy per un motorini da 500 W mi sembran tanti, specialmente a 24 V.

Io starei sui 15mHy-20mHy e sui 4-6 ohm di resitenza di armatura.

Che lo LM324, come ho scritto prima, non sia esageratamente veloce è vero, però dovrebbe essere sufficente per quel tipo di circuito. Puoi sempre fare una prova. Sotitusci l'ampli con altro tipo più veloce. In simulazione è un attimo. Così verifichi se, a parità di condizioni, c'è un miglioramento significativo.

Edited by Livio Orsini
Link to post
Share on other sites
divincodino

scusissime ho scritto male io :D intendevo di aver sostituito 100uH con 700uH (micro non milli per essere chiari) :D

Link to post
Share on other sites
Livio Orsini

Comunque i volori per quel tipo di motore son quelli che ti ho riportato.

Link to post
Share on other sites
divincodino

ok grazie mille :)

Il problema persiste, nel senso che al variare del carico la limitazione agisce diversamente, non mi resta che provare a dimensionarlo con valori tipici e vedere come si comporta il circuito nella realtà con il motore che ho a disposizione

Link to post
Share on other sites
divincodino

Buongiorno a tutti,

giusto per tenerne conto, ho simulato il circuito su altri 2 software, uno free e l'altro disponibile solo nei lab dell'università, e il risultato non cambia, al diminuire della resistenza di carico la limitazione non fornisce i risultati voluti, quindi o è un problema comune a tutti i software o in effetti in quelle condizioni il circuito non può funzionare, boh :blink: vedremo sulla board come andranno le cose

Link to post
Share on other sites
divincodino

Un'ultima domanda pongo a tutti quanti, ma specialmente a Livio e Mirko che aveva accennato a qualcosa: nel caso di 25A si parlava di potenziare la rete di pilotaggio, specialmente credo si parlasse del totem pole, potete suggerirmi qualcosa al riguardo? Ad esempio ho visto configurazioni come quella di Mirko con una resistenza di pulldown sul gate del mosfet, altre con una resistenza di pullup, altre con una resistenza di pullup sulla base del'npn del totem pole, ma non capisco bene quale sia la configurazione migliore e che permette di avere una maggiore durata dei componenti. Inoltre tenete presente che nel mio caso alimento tutto il circuito di gestione a 10-12V, mentre il motore a 24, quindi conviene alimentare a 24 il circuito a partire dal CA3130 o dal totem pole? grazie a tutti per la disponibilità :thumb_yello:

Link to post
Share on other sites
Livio Orsini

Ho fatto una simulazione del regolatore di Mirko tramite LTSpice. Il regolatore fa esattamente quello che deve fare.

Quando la tensione ai capi dello shunt è maggiore della tensione di riferimento lo stadio comparatore commuta causando la commutazione del secondo stadio; questas commutazione cambia il livello di riferimento, alzandolo, dell'amplificatore di tensione che regola la soglia di comparazione con la tensione a dente di sega. Quindi il duty cycle del PWM si riduce, riducendo quindi il valore termico della corrente.

Da quello che ho capito io i valori di questo circuito sono stati ottimizzati per lavorare tra 2 A e 10 A circa. Per farlo lavorare bene nell'intorno dei 20 A - 25 A dovresti rivedere le ottimizzazioni.

Edited by Livio Orsini
Link to post
Share on other sites
Mirko Ceronti
Ho fatto una simulazione del regolatore di Mirko tramite LTSpice. Il regolatore fa esattamente quello che deve fare.

Da quello che ho capito io i valori di questo circuito sono stati ottimizzati per lavorare tra 2 A e 10 A circa. Per farlo lavorare bene nell'intorno dei 20 A - 25 A dovresti rivedere le ottimizzazioni.

Grazie Livio :thumb_yello:

Link to post
Share on other sites
divincodino

Ok :)

allora visto che tu hai simulato il circuito esatto di Mirko io simulerò prima di tutto il mio anche con LTSpice e vediamo se il problema persiste, in tal caso evidentemente ci sarà qualcosa di sbagliato

Link to post
Share on other sites
Livio Orsini
allora visto che tu hai simulato il circuito esatto di Mirko io simulerò prima di tutto il mio anche con LTSpice e vediamo se il problema persiste, in tal caso evidentemente ci sarà qualcosa di sbagliato

No! Non c'è qualche cosa di sbagliato; c'è che tu pretendi faccia qualche cosa per cui non è stato ottimizzato. :smile:

Rileggi attentamente il mio messaggio #138

Link to post
Share on other sites
divincodino

eh ma a me non da lo stesso comportamento anche se metto il circuito originale :)

scusa ma dove trovo i modelli di LTSpice non presenti in libreria? ad esempio LM324 e NE555

Link to post
Share on other sites
Mirko Ceronti
eh ma a me non da lo stesso comportamento anche se metto il circuito originale :smile:

E quindi come si spiega il fatto che invece il circuito originale VERO (e non simulato) funziona egregiamente ????

E' che con questo caldo non ne ho voglia, ma ci sarebbe da fare un video con la telecamenra puntata sull'amperometro, che mostra come la lancetta dello strumento inserita in serie al carico con un limite di corrente tarato ad (esermpio) a 6 Ampere, non muove di un pelo quando il carico viene raddoppiato o triplicato.

Usando come carico delle lampade alogene da 12 volt 50 Watt in parallelo, si può vedere come la luminosità di queste cala ad ogni inserzione di una lampada in più, ma la corrente massima non si sposta dal limite del set-point.

Saluti

Mirko

Link to post
Share on other sites
Livio Orsini

NE555 è presente in libreria, mentre non lo è lo LM324. O usi un modello che abbia caratteristiche analoghe (come ho fatto io) o ti fai il modello. Idem per i transistori.

eh ma a me non da lo stesso comportamento anche se metto il circuito originale

Questo è normale.

Probabilmente come ho spiegato il fenomeno nel mio precedente messaggio risulta di ardua comprensione per te. :smile:

Se lavori con carichi < 10 A il sistema regola egregiamente; se vai oltre esci dalle prestazioni previste ed regolatore non è più in grado di effettuare la limitazione corretta. Per andare oltre questo limite è necessario rivedere almeno il dimensionamento del regolatore di corrente! Non basta variare il livello di riferimento.

Link to post
Share on other sites
divincodino

Scusa Livio ma io non trovo neanche l'NE555 :D

Ah ok, questo è di mia comprensione, non avevo capito cosa intendessi, colpa mia :)

La parte di regolazione che non riesce ad agire per carichi superiori a 10A intendi quella del totempole? perchè questa parte ho provato a modificarla, utilizzando altri transistor che erogano una corrente maggiore e quindi dovrebbero impennare il fronte della tensione di gate del mosfet di potenza. Sicuramente non so bene come realizzare la circuiteria ausiliaria completa, magari se Mirko fosse così gentile da darmi un'idea rapida gli sarei grato :)

Link to post
Share on other sites
Livio Orsini
intendi quella del totempole?

NO!

Il regolatore di corrente è la circuitazione relativa ai primi 3 amplificatori.

Poi ci possono anche essere problemi di pilotaggio del mosfet e altro, ma la parte di potenza non l'ho nemmeno simulata.

Lo NE555 lo trovi nella cartella \misc della libreria componenti.

Link to post
Share on other sites
Mirko Ceronti
magari se Mirko fosse così gentile da darmi un'idea rapida gli sarei grato :smile:

Io invece ancor più grato Ti sarei, se Tu realizzasti il circuito dal vero, e per prestazioni massime da 10 Ampere, ossia quello presentato a pagina 1 !

Così poniamo termine a questo rimpallo continuo di dubbi e perplessità gratuite su un circuito per altro stracollaudato.

Mi sembra stia diventando la storia del calabrone che in teoria non può volare, ma che invece VOLA (eccome se vola) in barba a tutti i modelli fisico-matematici conosciuti.

(infatti mi par di ricordare che solo recentemente si è riusciti a dimostrane il perchè del volo dopo decenni e decenni di studi.....che ridere)

Poichè non merito certo una simile considerazione, (per un circuito del genere poi) auspico che la realizzazione pratica dello schema, ponga fine a questa telenovela :smile:

Saluti

Mirko

Link to post
Share on other sites
Livio Orsini
Mi sembra stia diventando la storia del calabrone che in teoria non può volare,...

Questa è una leggenda metropolitana. In effetti gli studi della NASA avevano messo in evidenza la scarsa efficienza del volo del calabrone e della libellula rispetto a quello dia ltri insetti alati.

In effetti quando i calabroni mi mangiano le pere riesco ad abbatterli più facilmente perchè, appesantiti dal aluto pasto, fanno fatica a restare in volo. (questo lo sperimento sempre tra settembre ed ottobre :lol: )

Il problema del tuo circuito è differente. Non si tratta di discrepanze tra teoria e pratica, ma solo di teoria mal applicata. :smile:

Link to post
Share on other sites
divincodino

Chiedo scusa :)

innanzitutto per Mirko, spero di realizzarlo al più presto, sono tornato ieri mattina a casa dopo 12 ore di macchina e ho ancora avuto modo di realizzarlo ;)

Per Livio, hai perfettamente ragione, la regolazione di corrente parte dal primo trimmer, pensavo ti riferissi alla corrente erogata per gestire il finale, ci siam capiti male, o meglio ti ho capito male :D

Link to post
Share on other sites
divincodino

Scusatemi, in effetti non capisco il circuitino di partenza per la regolazione della corrente, esattamente non capisco la funzione del condensatore da 10uF e il diodo LM336...

Link to post
Share on other sites
Guest
This topic is now closed to further replies.


×
×
  • Create New...